Теги:Введение

Теги HTML

Тег HTML состоит из следующих друг за другом в определенном порядке элементов:

  • левой угловой скобки < (такого же, как "меньше чем" символа)
  • необязательного слэша /, который означает, что тег является конечным тегом, закрывающим некоторую структуру. Таким образом в этом контексте Вы можете читать символ /, как конец...
  • имени тега, например TITLE или PRE
  • необязательных, если даже тег может иметь их, атрибутов. Тег может быть без атрибутов или сопровождаться одним или несколькими атрибутами, например: ALIGN=CENTER
  • правой угловой скобки > (такой же, как символа "больше чем").

Примеры:

<H1>

<H1 ALIGN=LEFT>

Элементы HTML

Большинство, но не все теги HTML спарены так, что за открывающим тегом следует соответствующий закрывающий тег, а между ними содержится текст или другие теги, например:

<H1>Foreword</H1>

В таких случаях два тега и часть документа, отделенная ими, образуют блок, называемый HTML элементом. Некоторые теги, например <HR>, являются элементами HTML сами по себе, и для них соответствующий конечный тег неверен. Далее мы будем называть теги по их именам, опуская обязательные угловые скобки.

Aтрибуты

Для каждого тега определяется множество возможных атрибутов. Большинство тегов допускает один или несколько атрибутов, однако атрибутов может и совсем не быть. Спецификация атрибута состоит из расположенных в следующем порядке:

  • имени атрибута, например WIDTH
  • знак равенства (=)
  • значения атрибута, которое задается строкой символов, например, "80".

Всегда полезно заключить значение атрибута в кавычки, используя либо одинарные ('80'), либо двойные кавычки ("80"). Строка в кавычках не должна содержать такие же кавычки внутри себя. Так, если дата заключена в двойные кавычки, используйте одинарные кавычки для последующего заключения в кавычки, и наоборот. Предпочтительно использование двойных кавычек, так как для глаза человека бывает трудно отличить одинарные кавычки от символов, подобных символам акцентирования.

Вы можете также опустить кавычки для значений атрибутов, которые состоят только из следующих символов (обратитесь к технической концепции имени):

  • символов английского алфавита (A - Z, a - z)
  • цифр (0 - 9)
  • промежутков времени
  • дефисов (-)

Таким образом, WIDTH=80 и ALIGN=CENTER - разрешенное сокращение для WIDTH="80" и ALIGN="CENTER". Ссылка на URL, например, HREF=foo.htm, допустима, однако, когда URL используется с атрибутами, он должен быть заковычен, например HREF="http://www.hut.fi/". Существуют некоторые броузеры, которые допускают отсутствие кавычек или наличие элементов с открывающими кавычками без закрывающих. Однако, такую практику лучше не применять.

В пределах значения атрибута теги HTML не воспринимаются. А escape последовательности распознаются и интерпретируются, как символы.

Если значение атрибута такое же, как его имя, может быть использован минимальный синтаксис атрибута. То есть <UL COMPACT="COMPACT"> можно сократить до <UL COMPACT>. Некоторые агенты пользователей (программы просмотра пользователя, броузеры) даже требуют минимизации для некоторых атрибутов (COMPACT, ISMAP, CHECKED, NOWRAP, NOSHADE, NOHREF). Так что лучше использовать минимизированный синтаксис там, где это возможно.

Значения атрибутов должны быть отделены пробелами или незаполненными строками.

Чувствительность к регистру

Что касается имен тегов, атрибутов и большинства значений атрибутов, HTML нечувствителен к регистру. Вы можете, например, написать TITLE, или Title, или title, или даже tItLE, если Вам нравится.Но существуют и чувствительные к регистру конструкции языка, а именно:

  • escape последовательности (более официально называемые символьными объектами), которые начинаются знаком & (например, &lt;)
  • URL, так как он может содержать наименования файлов, которые являются case чувствительными во многих операционных системах (например, в Unix).

Разделение на строки и использование пробелов и символов табуляции

Когда документ выводится на экран, пробелы и пустые линии не сохраняются, за исключением текста, заключенного в теги PRE (предварительно отформатированный текст). То есть любая последовательность пробелов, символов табуляции и пустых линий эквивалентна единственному пробелу в файле HTML. С другой стороны, пробел в файле HTML может быть представлен с использованием любого количества пробелов или новыми (пустыми) строками.


!--

Тег <!-- ...-->

Элемент !-- определяет комментарий, невидимый при просмотре страницы. Между двумя тегами находится ваш текст. Часто бывает необходим при использовании новых тегов, не поддерживаемых в старых браузерах. В этом случае новые теги, обрамленных комментариями не будут отображаться в старых браузерах как непонятный текст

Пример
А ссылку вы видите!
А выглядит код так:
<!-- Это комментарий, но вы его не видите -->

<a href="a.html">А ссылку вы видите!</a>
Категория
Другие теги


!DOCTYPE

Тег <!DOCTYPE>

Тег !DOCTYPE сообщает валидатору, какую именно версию HTML вы используете в своей странице. Этот тег должен всегда находиться в первой строке каждой страницы. Тег !DOCTYPE - ключевой компонент web-страниц, претендующих на соответствие стандартам: без него ваш код и CSS не пройдут проверку валидатором. Закрывающий тег не требуется. Документация на данный тег достаточна туманна, поэтому предлагаются следующие варианты, которые "считаются правильными"

Пример
Стандарт HTML 4.01 Strict (строгий), Transitional (переходный), Frameset (с фреймами)
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
Категория
Другие теги


A

Тег <A>

Тег <A> служит для создания гипертекста (ссылок). Гипертекст позволяет осуществлять мгновенный переход от одного фрагмента текста к другому. Сам гипертекст поддается форматированию. Закрывающий тег обязателен. Тег должен содержать либо атрибут name, либо href

Атрибуты
contentEditable
Возможность редактирования
innerText
Текст между начальным и закрывающим тегом
name
Задает имя элемента. Имя используется, например, для создания ссылок между фреймами
href
Задает URL ресурса, на который должен перейти пользователь, щелкнув по ссылке. Атрибут может указывать как на внешний документ, так и на элемент внутри данного документа.
Для создания гиперссылки вызова почтовой программы для написания письма используется <a href="mailto:your@email">. Причем многие почтовые программы позволяют заполнить многие поля (все поля опционны, вы можете заполнять только те что нужны):
Параметры соединяются символом &, для пробелов используйте %20, для перевода на новую строку в сообщении - %0d%0a
mailto:terminator2@mail.ru?subject=HTML%20в%20примерх&Body=Отличный%20справочник%20Так%20держать!&CC=billgates@microsoft.com&BCC="wwwind@aport.ru (subject - тема письма, Body - содержание письма, CC - копия на другой адрес)
target
Строка, определяющая или получающая одно из следующих значений
name | Имя ссылки или фрейма
_blank | Загружает ссылку в новое окно
_parent | Загружает ссылку в родительском окне
_search | Загружает ссылку в панель поиска браузера. Доступно в Internet Explorer 5 и выше
_self | По умолчанию. Загружает ссылку в это же окно, где был произведен клик по ссылке
_top | Загружает ссылку в topmost окно
title
Всплывающая подсказка
Пример

Это обычный текст
А это уже гиперссылка на сайт http://www.xakep.ru
Пишите письма - пример для вызова почтовой программы

Код для примера

<a href="http://www.xakep.ru" title="подсказка">А это уже гиперссылка на сайт http://www.xakep.ru</a>
Категория
Гиперссылки


ABBR

Тег <ABBR> используется для аббревиатуры. Закрывающий тег обязателен

Атрибуты
title
Всплывающая подсказка
Пример

СНГ - Содружество независимых государств

Код для примера
<abbr>СНГ</abbr> - Содружество независимых государств

Категория
Теги логического форматирования текста


ACRONYM

Тег <ACRONYM> и обязательный парный ему </ACRONYM>

Тег <ACRONYM> идентифицирует акроним

Пример

СНГ - Содружество независимых государств

Код для примера
<ACRONYM>СНГ</ACRONYM> - Содружество независимых государств

Категория
Теги логического форматирования текста


ADDRESS

Тег <ADDRESS> и обязательный парный ему </ADDRESS>

Тег <ADDRESS> применяется для идентификации автора документа и указания адреса автора. Сюда же обычно помещаются и сведения об авторских правах, а также дата создания и последней модификации документа. Тег применяется обычно вначале или в конце документа. Текст, заключенный между тегами <address></address> обычно отображается курсивом

Пример

Мой адрес - Советский Союз

Код для примера
<address>Мой адрес - Советский Союз</address>

Категория
Другие теги


APPLET

Тег <APPLET>

Тег APPLET это маленькие по объему файлы с расширением .class, предназначенные для вставки его в html-документы с целью получения самых разнообразных эффектов. Закрывающий тег обязателен

Атрибуты
align
Выравнивание элемента. Может принимать значения: BSBOTTOM, ABSMIDDLE, BASELINE, BOTTOM, LEFT, MIDDLE, RIGHT, TEXTTOP, TOP
code
Имя файла, содержащего скомпилированный java class
Пример

Взято с сайта http://www.dataway.ch/~bennet/

Код
<TABLE cellSpacing=0 cellPadding=0 bgColor=#000000 border=3>
<TBODY>
<TR>
<TD align=middle>
<APPLET height=120 width=120 align=center
                  code=Clock3D>
<PARAM NAME="12hour" VALUE="0">
<PARAM NAME="a1" VALUE="4000">
<PARAM NAME="bgcolor" VALUE="#000000">
<PARAM NAME="color" VALUE="#00FF66">
<PARAM NAME="fps" VALUE="16">
<PARAM NAME="irotx" VALUE="0">
<PARAM NAME="iroty" VALUE="0">
<PARAM NAME="irotz" VALUE="0">
<PARAM NAME="pixangle" VALUE="4">
<PARAM NAME="pixd" VALUE="8">
<PARAM NAME="radius" VALUE="6">
<PARAM NAME="rotx" VALUE="0">
<PARAM NAME="roty" VALUE="-4">
<PARAM NAME="rotz" VALUE="0.401">
<PARAM NAME="style" VALUE="1">
</APPLET>
</TABLE>
Категория
Другие теги


AREA

Тег <AREA> и необязательный закрывающий </AREA>

Элемент AREA определяет фигуру и координаты чувствительных областей в MAP

Атрибуты
coords
Координаты чувствительных областей. Задание координат зависит от параметра shape
форма области | COORDS
RECT - прямоугольник | COORDS="A,B,C,D", где A,B - координаты верхнего левого угла области. C,D - координаты правого нижнего угла области.
CIRC - окружность | COORDS="A,B,C", где A,B - координаты центра окружности. C - радиус окружности.
POLY - многоугольник | COORDS="A,B,C,D, ... ,A,B". Каждая пара задает координаты вершин многоугольника. Первая и последняя пары совпадают задавая замкнутую фигуру.
href
Ссылка
nohref
Ссылка для заданной области отсутствует
shape
Тип фигуры. Может принимать следующие значения: RECT (прямоугольник), CIRC (окружность), POLY (многоугольник)
Пример
первая область вторая область А выглядит код так:
<MAP NAME="test">
<!-- верхний левый и правый нижний углы -->
<AREA HREF="1.html" ALT="первая область" SHAPE="rect" COORDS="0,0,100,130">

<!-- центр окружности и радиус -->
</MAP>
<AREA HREF="2.html" ALT="вторая область" SHAPE="circle" COORDS="150,65,65">

<img src="../cat.jpg" width=200
height=130 border="0" usemap="#test">
Категория
Другие теги


B

Тег <B>

Тег B создает жирный текст. Закрывающий тег обязателен

Атрибуты
contentEditable
Возможность редактирования
innerText
Текст между начальным и закрывающим тегом
title
Показывает текст в виде всплывающей подсказки
Пример

Это обычный текст
А это уже жирный текст с использованием тега <B>

Категория
Теги физического форматирования текста


BASE

Тег BASE позволяет авторам явно указать базовый URL документа. Если BASE указан, он должен присутствовать в разделе HEAD документа HTML, до элементов, ссылающихся на внешние ресурсы. Информация о пути, указанная в элементе BASE, влияет только на URL в документе, в котором присутствует этот элемент. Начальный тег обязателен, конечный тег запрещен

Атрибуты
href=
задает абсолютный URL, служащий базовым URL для разрешения относительных URL
Пример
<HTML>
<HEAD>
  <BASE HREF="http://winchanger.narod.ru/"/>
</HEAD>

<BODY>
Щелкни здесь, чтобы узнать больше
</BODY>
</HTML>
Категория
Теги форматирования документа


BGSOUND

Тег <BGSOUND> служит для внедрения звуковых файлов на страницы в качестве фоновой музыки. Возможные форматы: wav, midi и некоторые другие. Закрывающий тег не требуется

Атрибуты
balance = "целое число"
Определяет, как звук распределяется между левой и правой колонкой. Может принимать значения от -10000 (только левая) до +10000 (только правая). По умолчанию 0 (центр).
loop = "значение"
Возвращает или устанавливает число повторов. Может принимать следующие значения
-1 | Постоянное воспроизведение звука
0 | Только один раз
n | Устанавливает точное число повторов
src = "URL"
URL звукового файла
volume="неположительное число"
Определяет, как громко будет звучать фоновая музыка относительно уровня громкости на компьютере пользователя. Максимальное значение = 0 - соответствует заданному пользователем значению. Можно делать только тише: до -10000 (хотя у большинства пользователей звук пропадает уже при значении, гораздо большем, чем -10000).
Пример

Код с использованием тега <BGSOUND>
<bgsound src="newalert.wav" loop=5>

Категория
Звук


BIG

Тег <BIG> и обязательный парный ему </BIG>

Тег <BIG> выводит более крупный текст

Атрибуты
innerText
Текст между начальным и закрывающим тегом
title
Показывает текст в виде всплывающей подсказки
Пример

Это обычный текст
А это уже более крупный текст с использованием тега <BIG>

Категория
Теги физического форматирования текста


BLOCKQUOTE

Тег <BLOCKQUOTE> и обязательный парный закрывающий тег </BLOCKQUOTE>

Тег <BLOCKQUOTE> предназначен для включения в документ длинных цитат, cоздавая отступы с обеих сторон текста и отделяясь от остального текста пустыми строками

Пример

Это обычный и очень длинный текст, который весьма неудобно читать, если он написан в одну строчку

А это уже длинный текст c отступами от сторон текста для лучшего восприятия

Категория
Теги форматирования текста


BODY

Тег BODY

Тег <BODY> определяет видимую часть документа.В этом разделе располагается вся содержательная часть документа (текст статьи, фотографии, формы для заполнения, другие объекты).Тег имеет ряд необязательных атрибутов. Рекомендуется вместо нежелательных атрибутов использовать каскадные таблицы стилей. Начальный и конечный теги необязательны

Атрибуты
bgcolor
Устанавливает цвет фона документа, используя значение цвета в виде RRGGBB - пример: FF0000 - красный цвет, либо используя константы цвета, например для желтого цвета, используемой на данной странице <body bgcolor= "yellow">
background
Нежелательный. Указывает на url-адрес изображения - фона документа
contentEditable
Возможность редактирования
innerText
Текст между начальным и закрывающим тегом
offsetWidth
Размер объекта
text
Нежелательный. Устанавливает цвет текста документа, используя значение цвета в виде RRGGBB - пример: 000000 - черный цвет, либо используя константы цвета, например для зеленого цвета, используемой на данной странице <body text= "green">
link
Нежелательный. Устанавливает цвет гиперссылок, используя значение цвета в виде RRGGBB - пример: 00FF00 - зеленый цвет,либо используя константы цвета,например для красного цвета,используемой на данной странице <body link= "red">
Пример красной ссылки
vlink=
Нежелательный. Устанавливает цвет гиперссылок на которых вы уже побывали, используя значение цвета в виде RRGGBB - пример: 333333 - серый цвет
alink=
Нежелательный. Устанавливает цвет гиперссылок при нажатии. Например, на этой странице ссылки становятся синими при нажатии мышкой
bgproperties=fixed
Фоновое изображение прокручиваться не будет. Т.е. текст будет двигаться при нажатии PageDown, а фон - нет. Данный параметр поддерживается только Internet Explorer
Эти параметры можно объединять, например на этой страничке используется <BODY bgcolor="yellow" text="green" link="red" alink="blue">
Категория
Теги форматирования документа


BR

Тег <BR> не требует парного закрывающего тега

Тег <BR>(BReak line) вставляет перевод строки

Пример

Это обычный и очень длинный текст, который весьма неудобно читать, если он написан в одну строчку

А это уже длинный текст, разбитый
на две строки с помощью тега <BR>

Категория
Теги форматирования текста


BUTTON

Тег <BUTTON>

Тег <BUTTON> создает кнопку с рисунком или с другими встроенными элементами. Закрывающий тег </BUTTON> требуется

Атрибуты
disabled
Делает кнопку недоступной
innerText
Текст между начальным и закрывающим тегом
style
Задает стили для кнопки. Например, размеры кнопки
title=
Всплывающая подсказка
type=
Тип кнопки

Пример

Код для первой кнопки

<button>
 <table border=1>
  <tr>
  <td>Кнопочка
  <tr>
  <td>в таблице
  </table></button>
Код для второй кнопки
<button disabled title="я кнопка">Я недоступна!</button>
Категория
Элементы управления


CAPTION

Тег <CAPTION>

Тег <CAPTION> определяет заголовок для таблицы TABLE. Элемент CAPTION может располагаться только непосредственно после начального тега TABLE. Элемент TABLE может включать только один элемент CAPTION. Закрывающий тег обязателен.

Атрибуты
align=
Не рекомендуемый параметр. Выравнивание заголовка относительно таблицы. Возможные значения: left, right, top (по умолчанию), bottom
innerText
Текст между начальным и закрывающим тегом
title
Всплывающая подсказка
Пример

Пример простой таблицы
Мой заголовок таблицы
Заголовок столбца 1 | Заголовок столбца 2
Ячейка столбца 1, ряд 1 | Ячейка столбца 2, ряд 1
Ячейка столбца 1, ряд 2 | Ячейка столбца 2, ряд 2

Код для таблицы
<TABLE BORDER=2 COLS=2 BGCOLOR=yellow align=center>
<caption>Мой заголовок таблицы</caption>
 <TR>
  <TH>Заголовок столбца 1</TH><TH>Заголовок столбца 2</TH>
 </TR>
 <TR>
  <TD>Ячейка столбца 1, ряд 1</TD><TD>Ячейка столбца 2, ряд 1</TD>
 </TR>
 <TR>
  <TD>Ячейка столбца 1, ряд 2</TD><TD>Ячейка столбца 2, ряд 2</TD>
 </TR>
</TABLE>
Категория
Таблицы


CENTER

Тег <CENTER> и обязательный парный ему </CENTER>

Тег <CENTER> предназначен для горизонтального выравнивания ВСЕХ элементов посередине окна браузера. CENTER это тег уровня блока, поэтому им можно центрировать, например, таблицы, тексты

Пример

Это обычный текст

А это уже текст с использованием тега <center>

Категория
Другие теги


CITE

Тег <CITE> и обязательный парный ему </CITE>

Тег <CITE> используется для цитат, названий книг. Обычно наклонный текст

Атрибуты
innerText
Текст между начальным и закрывающим тегом
title
Всплывающая подсказка
Пример

Это обычный текст
А это уже текст с использованием тега <CITE>

Категория
Теги логического форматирования текста


CODE

Тег <CODE> и обязательный парный ему </CODE>

Тег <CODE> отмечает текст как небольшой фрагмент программного кода. Обычно отображается моноширинным шрифтом

Атрибуты
innerText
Текст между начальным и закрывающим тегом
title
Всплывающая подсказка
Пример

Это обычный текст
А это уже текст с использованием тега <CODE>

Категория
Теги логического форматирования текста


contentEditable

Атрибут contentEditable

Атрибут contentEditable позволяет пользователю редактировать содержимое объекта. Доступно, начиная с версии Internet Explorer 5.5

Синтаксис

<Element contentEditable = sCanEdit...>
sCanEdit может принимать следующие значения
inherit | По умолчанию. Содержимое объекта можно редактировать зависит от родительского объекта
false | Пользователь не может редактировать содержимое объекта
true | Пользователь может редактировать содержимое объекта
Пример

Текст с использованием тега <center>, который вы можете редактировать!

Второй пример позволяет с помощь скрипта отключать и включать возможность редактирования

Нажмите на кнопку для возможности или запрета редактирования содержимого тега SPAN.

Вы можете изменять этот зеленый текст

SPAN можно редактировать:


DD

Тег <DD> и необязательный парный ему </DD>

Тег <DD>(Definition Description) является описанием списка определений

Пример
Это определение
Описание определения
А выглядит код так:
<DL title="это список">
 <DT>Это определение
 <DD>Описание определения
 </DL>
Категория
Списки


DFN

Тег <DFN> и обязательный парный ему </DFN>

Тег <DFN> отмечает текст как определение (DeFeNition). Этим тегом можно отметить термин, впервые встречающийся в документе

Атрибуты
innerText
Текст между начальным и закрывающим тегом
title
Всплывающая подсказка
Пример

Это обычный текст
Интернет - это...
Вторая строка с использованием тега <DFN>

Категория
Теги логического форматирования текста


DIV

Тег <DIV>

Элемент DIV определяет контейнер для HTML. Данный элемент предназначен для использования в CSS. Закрывающий тег: требуется. Весьма схож с элементом SPAN, но при этом браузеры обычно помещают символ перевода строки перед и после этого элемента (Смотри пример)

Атрибуты
align
Выравнивает элемент к одной из сторон документа или таблицы (left, right, center, justify)
contentEditable
Возможность редактирования
innerText
Текст между начальным и закрывающим тегом
title
Всплывающая подсказка
UNSELECTABLE
Запрещает или разрешает выделять текст в данном элементе (on - запрещает, off - разрешает)

Пример

Строка содержит одно слово

красного
цвета. Причем это слово нельзя выделить. Обратите внимание, что красное слово начинается с новой строки и выравнено по центру и следующее слово начинается опять с новой строки

А выглядит код так: <P>Строка содержит одно слово <div STYLE="color: red" UNSELECTABLE="on" align="center">красного</div> цвета.

Категория
Другие теги


DL

Тег <DL> и необязательный парный ему </DL>

Тег <DL>(Definition List) служит для создания списка определений. Списки состоят из двух частей: определения (DT) и описания (DD)

Атрибуты
title
Показывает текст в виде всплывающей подсказки
Пример
HTML
Это язык разметки гипертекста
Браузер
Это программа для просмотра гипертекста в интернете
А выглядит код так:
<DL title="это список">
 <DT>HTML
  <DD>Это язык разметки гипертекста
 <DT>Браузер
  <DD> Это программа для просмотра гипертекста в интернете
</DL>
Категория
Списки


DT

Тег <DT> и необязательный парный ему </DT>

Тег <DT>(Definition Term) является определением списка определений

Пример
Это определение
Описание определения
А выглядит код так:
<DL title="это список">
 <DT>Это определение
 <DD>Описание определения
 </DL>
Категория
Списки


EM

Тег <EM> и обязательный парный ему </EM>

Тег <em> используется для выделения, подчеркивания важных фрагментов текста курсивом (наклонный текст). Происходит от слова emphasis - акцент. Аналогичен тегу I

Пример

Это обычный текст
А это уже текст с использованием тега <em>

Категория
Теги логического форматирования текста


FIELDSET

Тег <FIELDSET>

Тег <FIELDSET> рисует рамку вокруг текста и других объектов, содержащихся в контейнере. Закрывающий тег требуется

Атрибуты
Примеры
Группа кнопочек

Два текстовых поля
Категория
Элементы управления


FONT

Тег <font>

Тег <font> определяет выводимый шрифт, его цвет и размер. Закрывающий тег требуется

Атрибуты
color
Устанавливает цвет текста, используя значение цвета в виде RRGGBB - пример: FF0000 - красный цвет, либо используя константы цвета,например для зеленого цвета<font color= "green">
face
Определяет гарнитуру шрифта
size
Размер текста в пределах от 1 до 7,где 1 - самый мелкий шрифт. По умолчанию равен 3
Примечание: Атрибуты можно объединять
Пример

Это обычный текст
А это уже текст с использованием тега <font size=1>
Текст с использованием шрифта семейства courier
Используем тег <font size=5 color="blue">

Категория
Теги форматирования текста


FORM

Тег <FORM>

Тег FORM является контейнером для элементов управления и предоставляет возможность вводить информацию и отправлять ее на сервер. Создание вложенных форм не допускается. Закрывающий тег требуется

Атрибуты
action
Указывает адрес, по которому выполняется обработка формы
method
Способ пересылки формы на серве. Возможны два значения - GET и POST
name
Имя формы для доступа к ее элементам из скриптовых языков
Пример

Категория
Другие теги


FRAME

Тег <frame>

Тег <frame> служит для описания одного фрейма (его вид и содержание). Закрывающий тег не требуется

Атрибуты
name
Назначает имя текущему фрейму. Это имя может использоваться в качестве цели в последующих ссылках
src
Определяет исходный документ, содержащийся в фрейме
noresize
Если этот атрибут присутствует, он сообщает агенту пользователя, что размеры фрейма изменять нельзя
Пример

Простейший пример фреймов

<HTML>
<HEAD>
<TITLE>Пример фреймов</TITLE>
</HEAD>
<FRAMESET COLS="30 %, *">
<FRAME SRC="leftframe.html">
<FRAME SRC="rightframe.html">
</FRAMESET>
</HTML>

Категория
Теги форматирования текста


FRAME

Тег <frame>

Тег <frame> служит для описания фрейма. Закрывающий тег не требуется

Атрибуты
src
Адрес объекта (страницы)
Пример

Простейший пример фреймов

<HTML>
<HEAD>
<TITLE>Пример фреймов</TITLE>
</HEAD>
<FRAMESET COLS="30 %, *">
<FRAME SRC="leftframe.html">
<FRAME SRC="rightframe.html">
</FRAMESET>
</HTML>

Категория
Теги форматирования текста


HEAD

Тег <HEAD> и парный ему </HEAD>

Тег <HEAD> определяет место, где помещается различная информация не отображаемая в теле документа. Здесь располагается тег названия документа и теги для поисковых машин

Категория
Теги форматирования документа


HR

Тег <HR>. Закрывающий тег не требуется

Тег <HR> добавляет в HTML документ горизонтальную линию. Перед и после линии помещается пустая строка

Атрибуты
size
Устанавливает высоту(толщину) линии
width
Устанавливает ширину линии в пикселах или процентах
noshade
Создает линию без тени
color
Задает линии определенный цвет
Пример

Это обычная линия <hr>

Это линия потолще и красная <hr size=3 color=red>
Категория
Теги форматирования текста


HTML

Тег <HTML> и парный ему </HTML>

Тег <HTML> указывает программе просмотра страниц что это HTML документ

Категория
Теги форматирования документа


Hx

Теги <H1>, <H2>, <H3>, <H4>, <H5>, <H6>

Тег <Hx> служит для создания заголовка. Всего существует 6 видов заголовков - от H1 до H6. Тегу H1 соответствует самый большой заголовок, тегу H6 - самый маленький. Закрывающий тег требуется

Атрибуты
align
Выравнивает заголовок в соответствии со следующими значениями:
center | По центру
left | По левому краю
right | По правому краю
title
Всплывающая подсказка
Пример

Очень большой заголовок с тегом <H1>

Заголовок поменьше с тегом <H2 title="я-подсказка!">

Еще меньше с тегом <H3 align=right>

Маленький заголовок с тегом <H4>

Очень маленький заголовок с тегом <H5>
Самый маленький заголовок с тегом <H6 align=center>
Категория
Теги форматирования текста


I

Тег <i> и обязательный парный ему </i>

Тег <i> создает наклонный текст

Пример

Это обычный текст
А это уже наклонный текст с использованием тега <i>

Категория
Теги физического форматирования текста


IFRAME

Тег <IFRAME>

Тег <IFRAME> создает плавающее окно. Обязателен закрывающий тег

Атрибуты
align
Выравнивание. Аналогичен этому же параметру в IMG
frameborder
Выводит или не выводит рамку вокруг фрейма. Может принимать значения: 1 (по умолчанию, рамка выводится), 0 (рамка не выводится), yes (аналогично 1), no (аналогично 0)
height
Высота фрейма
marginheight
Отступы содержимого iframe от верхнего и нижнего края
marginwidth
Отступы содержимого iframe от левого и правого края
name
Имя фрейма. Позволяет загружать любую желаемую страничку в получаемое при помощи IFRAME окно
scrolling
Задает свойства скроллинга. Возможны три значения:
auto (по умолчанию, браузер самостоятельно определяет возможность скроллинга)
yes (скроллинг возможен)
no (скроллинг невозможен)
src
Адрес загружаемого документа
width
Ширина фрейма
Пример

Загрузим в плавающее окно какую-нибудь страничку справочника

Категория
Фреймы


IMG

Тег <IMG>

Тег IMG служит для внедрения графики на страницы. На данный момент поддерживаются форматы файлов GIF, JPG, JPEG, PNG. Возможно использование анимированных картинок (GIF). Чтобы картинка была одновременно и ссылкой, то поместите тег IMG между <a href=...><img src="xakep.gif"></a>

Атрибуты
src
Обязательный атрибут, указывающий URL рисунка
align
Выравнивает изображение к одной из сторон документа
left | Выравнивание по левому краю
right | Выравнивание по правому краю
center | Выравнивание по центру
bottom | Выравнивание по нижнему краю
top | Выравнивание по верхнему краю
middle | Выравнивание по середине
alt
Выводит текст к картинке. Полезно, если браузер не отображает графику на странице
border
Устанавливает толщину рамки вокруг изображения в пикселах. По умолчанию рамка не используется. При использовании изображения в качестве гиперссылки рекомендуется установить BORDER=0, чтобы подавить цветовую окантовку, которая появится вокруг изображения
GALLERYIMG =
Поддержка Панели управления изображениями. Данная панель появляется при нахождении указателя мыши на изображении и позволяет быстро сохранить картинку, распечатать, послать на e-mail, открыть папку Мои рисунки. По умолчанию данная панель появляется только при размерах более 130 пикселах. Но можно включить эту панель с помощью этого атрибута. Может принимать значениея yes (или true) и no (или false). Смотри также META
ismap
Сообщает, что изображение является картой-изображением на сервере
height
Высота картинки в пикселах или процентах. Всегда желательно явно устанавливать этот параметр для ускорения загрузки страницы браузером
hspace
Определяет размер свободного места в пикселах слева и справа от изображения, улучшает внешний вид страницы, отделяя изображение от текста
usemap
Сообщает, что изображение является картой-изображением на стороне клиента
vspace
Определяет размер свободного места в пикселах сверху и снизу от изображения, улучшает внешний вид страницы, отделяя изображение от текста
width
Ширина картинки в пикселах или процентах. Всегда желательно явно устанавливать этот параметр для ускорения загрузки страницы браузером
Пример

Отдыхаем!
Код с использованием тега <img>
<img src="../cat.jpg" alt="Отдыхаем!" vspace=10 GALLERYIMG="yes">

Картинка-ссылка
Категория
Графика


innerText

Атрибут innerText

Атрибут innerText устанавливает или получает текст между начальным и закрывающим тегом объекта. Для некоторых тегов данный атрибут доступен только для чтения (html, table, tBody, tFoot, tHead, tr).

Синтаксис

object.innerText [ = sTxt ]
sTxt - Строка, задающая текст между начальным и закрывающим тегом

Пример

На дисках к журналу Хакер вы можете найти последние версии моих справочников


INPUT

Тег <INPUT>

Тег <INPUT> предназначен для создания элементов управления и всегда используется совместно с атрибутом TYPE. Закрывающий тег не требуется

Атрибуты
title
Всплывающая подсказка
value
Задает отображаемый текст для text, password, button, reset, submit
size
Устанавливает число видимых символов в text
maxlength
Устанавливает максимально допустимое число вводимых символов в text
checked
False или True - Принимает начальное состояние для checkbox и radio (по умолчанию False)
type
Описывает тип интерфейсного элемента. Может принимать следующие значения
text | создает строку для ввода текста
password | создает строку для ввода текста, при этом отображает вводимые символы как звездочки (*)
checkbox | создает «включатель»
radio | создает «исключающий переключатель». Как правило, используют блоки из нескольких таких элементов
file | создает элемент для выбора локальных файлов. Например, строку для имени файла и кнопку "Обзор", при нажатии на которую открывается диалог «Выбор файла»
hidden | создает невидимый для пользователя элемент. Может использоваться для отправки дополнительной, служебной информации
image | создает элемент формы в виде кнопки-изображения
button | создает стандартную кнопку
submit | создает кнопку «Подача запроса»
reset | создает кнопку «Сброс»
style
Задает различные стили. Например, высоту или ширину элемента
Примеры

Радиопереключатели
Можно выбрать только один элемент
Попробуйте

Категория
Элементы управления


KBD

Тег <KBD> и обязательный парный ему </KBD>

Тег <KBD> отмечает текст, вводимый пользователем с клавиатуры. Отображается моноширинным шрифтом. От английского keyboard - клавиатура

Пример

Для запуска Windows наберите: win.

Код для примера
Для запуска Windows наберите: <kbd>win</kbd>

Категория
Теги логического форматирования текста


LEGEND

Тег <LEGEND>

Тег <LEGEND> выводит надпись для тега FIELDSET и должен быть в нем первым элементом. Закрывающий тег требуется

Атрибуты
Примеры
Группа кнопочек

Два текстовых поля
Категория
Другие теги


LI

Тег <LI> и необязательный парный ему </LI>

Тег <LI>(List Item) служит для обозначения элемента (строки) списка. Используется в нумерованных(OL) и ненумерованных(UL) списках

Пример
  1. Пугачева
  2. Орбакайте
  3. Киркоров
  4. Пресняков
А выглядит код так:
<OL type=A title="нумерованный список">
<LI>Пугачева
<LI>Орбакайте
<LI>Киркоров
<LI>Пресняков
</OL>
Категория
Списки


LINK

Тег LINK

Тег <LINK> определяет ссылку. В отличие от тега A, тег LINK может располагаться только в части заголовка HEAD документа. Информация, указанная в элементе LINK, может по-разному обрабатываться броузерами, в зависимости от указанных атрибутов. Закрывающий тег не требуется

Пример
Смотри информацию на CSS
<LINK REL="Stylesheet" HREF="default.css" TYPE="text/css">
Категория
Другие теги


MAP

Тег <MAP> и обязательный закрывающий </MAP>

Элемент MAP определяет коллекцию чувствительных областей в графическом изображении, при этом различные участки изображения могут быть ссылками на различные ресурсы. Чувствительные области задаются тегами AREA

Пример
первая область вторая область А выглядит код так:
<MAP NAME="test">
<!-- верхний левый и правый нижний углы -->
<AREA HREF="1.html" ALT="первая область" SHAPE="rect" COORDS="0,0,100,130">

<!-- центр окружности и радиус -->
</MAP>
<AREA HREF="2.html" ALT="вторая область" SHAPE="circle" COORDS="150,65,65">

<img src="../cat.jpg" width=200
height=130 border="0" usemap="#test">
Категория
Другие теги


MARQUEE

Элемент MARQUEE является ответом Microsoft на BLINK. MARQUEE заставляет текст не мигать, а прокручиваться, либо перемещаться из стороны в сторонуl. Требуется закрывающий тег

Атрибуты
BEHAVIOR=ALTERNATE | SCROLL | SLIDE
Определяет вид скроллинга
ALTERNATE | Колебательные движения налево и направо
SCROLL | Перемещение текста в направлении, указанном в DIRECTION. Достигнув края экрана, надпись появляется снова с противоположной стороны
SLIDE | Схоже с SCROLL, но текст перемещается только один раз и останавливается
DIRECTION=DOWN | LEFT | RIGHT | UP
Определяет направление скроллинга
DOWN | Движение вниз
LEFT | Движение справа налево. По умолчанию
RIGHT | Движение слева направо
UP | Движение вверх
loop="значение"
Задает, сколько раз прокрутится строка
scrollamount="значение"
Скорость движения строки. Может принимать значения от 1 до 10.
1 - самое медленное движение, 10 - самое быстрое
scrolldelay="значение"
Задержка между двумя движениями в миллисекундах. По умолчанию 85
bgcolor="цвет"
Цвет фона бегущей строки
height="значение"
Высота в пикселах или процентах
hspace="значение"
Определяет размер свободного места в пикселах слева и справа от бегущей строки
vspace="значение"
Определяет размер свободного места в пикселах сверху и снизу от бегущей строки
width="значение"
Ширина в пикселах или процентах
Пример ALTERNATE Черепаха SLIDE А выглядит код так:
<MARQUEE BEHAVIOR=ALTERNATE DIRECTION="right">Здесь ваш текст</MARQUEE>
Категория
Теги форматирования текста


MENU

Тег <MENU>

Тег MENU служит для создания ненумерованного списка. Данный тег является устаревшим и оставлен для совместимости со старыми браузерами. Закрывающий тег требуется

Атрибуты

title
Всплывающая подсказка
disabled
Если установить равным 1, то текст будет выведен серым цветом

Пример

  • Первый элемент меню
  • Второй элемент меню
    • А выглядит код так:
    <menu disabled=1 title="я - меню!">
<LI>Первый элемент меню
<LI>Второй элемент меню
</menu>
    Категория
    Списки


META

Тег META

Специальная группа инструкций <META>, предназначена в основном для описания и индексирования документа поисковыми машинами. Все тэги META не видны при просмотре документа. Команды <META> вносятся в "шапку" гипертекстового документа - внутри блока <HEAD>...</HEAD>. Закрывающий тег </META> запрещен

<META HTTP-EQUIV="Expires" CONTENT="Mon, 25 Sep 2002 00:02:01 GMT">

Используется для того, чтобы в нужное время браузер при просмотре документа брал не версию, хранящуюся в кэше, а свежую версию прямо с Вашего сайта.

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=Windows-1251">

Используется для того, чтобы браузер мог правильно отобразить содержимое страницы и для определения поисковой машиной языка, на котором написана страница

<META HTTP-EQUIV="Refresh" CONTENT="x; URL=http://winchanger.narod.ru/">

Используется для того, чтобы браузер автоматически переключался на новый адрес через x секунд

<META name="author" content="Arni Schwarz">

Используется для указания имени автора. Поисковые системы могут найти нужный сайт по имени автора (или найти самого автора).

<META name="copyright" content="&copy; 2001 SOFT BANANAS">

Полезно также указать и авторские права название фирмы почти наверняка будет проиндексировано поисковой машиной.

<META http-equiv="PICS-Label" content=' (PICS-1.1 "http://www.gcf.org/v2.5" labels on "1994.11.05T08:15-0500" until "1995.12.31T23:59-0000" for "http://w3.org/PICS/Overview.html" ratings (suds 0.5 density 0 color/hue 1)) '>

Еще одна интересная штучка отсечение нежелательных пользователей от указанной страницы (например, детей от секс-серверов), при помощи введения рейтинга - т.н. "красной лампочки". Некоторые браузеры позволяют "повесить замок" на содержимое определенных сайтов, запрещая их просмотр. Имеется несколько признанный рейтинговых систем, распознаваемых браузерами. Сам браузер, естественно, можно подстроить под использование рейтинга, а профиль пользователя браузера защитить паролем. Как правило, текст в этот тэг вставляется в строгом соответствии с текстом, имеющемся на рейтинговом сервере.

<META name="keywords" content="META, HTML, WWW, Web, паутина, поиск, определение, рекомендации, примеры использования, учебник, руководство, информация, справка, Netscape, Microsoft Internet Explorer">

Список терминов и ключевых слов это то, что является самым главным при индексировании Вашего сайта поисковой машиной! Длина содержимого тегов МЕТА "keywords" не должна превышать 1000 символов

<META name="description" content="The best homepage">

Краткое описание Вашего сайта, используемое поисковым сервером для индексирования, и, как правило, вставляемое в текст страницы найденных совпадений в качестве описания Вашего сайта. Длина содержимого тегов МЕТА "description" не должна превышать 200 символов

<META HTTP-EQUIV="imagetoolbar" CONTENT="no">

Отключает Панели управления изображениями. Обычно используют при выводе баннеров, фона картинки, карты изображения и др., когда вывод данной панели нежелателен

<META HTTP-EQUIV="MSThemeCompatible" Content="No">

Поддержка интефейса, используемого в Windows XP. Если вы пользуетесть Windows XP, то Internet Explorer 6 использует новый внешний вид некоторых элементов (кнопки, полосы прокрутки), как в Windows XP. Вы может отключить эту поддержку

Группа особых метатегов, позволяющих использовать особые эффекты при заходе или уходе пользователя со странички или сайта

<META HTTP-EQUIV="Page-Enter" CONTENT="revealTrans(Duration=4.0,Transition=12)"> (эффект при заходе на страницу)

<META HTTP-EQUIV="Page-Exit" CONTENT="revealTrans(Duration=4.0,Transition=12)"> (эффект при уходе со страницы)

<META HTTP-EQUIV="Site-Enter" CONTENT="revealTrans(Duration=4.0,Transition=12)"> (эффект при заходе на сайт)

<META HTTP-EQUIV="Site-Exit" CONTENT="revealTrans(Duration=4.0,Transition=12)"> (эффект при уходе с сайта),
где Duration задает время в секундах, а Transition - номер эффекта
Посмотреть примеры

Категория
Теги форматирования документа


Пример с META

Примеры

Группа особых метатегов, позволяющих использовать особые эффекты при заходе или уходе пользователя со странички или сайта

<META HTTP-EQUIV="Page-Enter" CONTENT="revealTrans(Duration=4.0,Transition=12)"> (эффект при заходе на страницу) (или Site-Enter)

<META HTTP-EQUIV="Page-Exit" CONTENT="revealTrans(Duration=4.0,Transition=12)"> (эффект при уходе со страницы) (или Site-Exit),
где Duration задает время в секундах, а Transition - номер эффекта

Список эффектов

  • 0 - Box in (в поле)
  • 1 - Box out (из поля)
  • 2 - Circle in (в круг)
  • 3 - Circle out (из круга)
  • 4 - Wipe up (стирание вверх)
  • 5 - Wipe down (вниз)
  • 6 - Wipe right (вправо)
  • 7 - Wipe left (влево)
  • 8 - Vertical blinds (вертикальные жалюзи)
  • 9 - Horizontal blinds (горизонтальные жалюзи)
  • 10 - Checkboard across (в шахматном порядке поперечно)
  • 11 - Checkboard down (вниз)
  • 12 - Random dissolve (случайный наплыв)
  • 13 - Split vertical in
  • 14 - Split vertical out
  • 15 - Split horizontal in
  • 16 - Split horizontal out
  • 17 - Strips left down
  • 18 - Strips left up
  • 19 - Strips right down
  • 20 - Strips right up
  • 21 - Random bars horizontal (случайные горизонтальные линии)
  • 22 - Random bars vertical
  • 23 - Random (случайный эффект)


NOBR

Тег <NOBR> (NO BReak line) запрещает перевод строки. Бывают случаи, когда возникает надобность в операции противоположного назначения – запретить перевод строки. Текст, заключенный между тэгами <NOBR> и </NOBR>, будет гарантированно располагаться в одной строке без переноса на другую. Длинная строка не уместится на экране, и для ее просмотра придется использовать горизонтальную полосу прокрутки. Закрывающий тег обязателен

Пример

Это обычный и очень длинный текст, который весьма неудобно читать, если он написан в одну строчку
Код для примера
<nobr>Это обычный и очень длинный текст, который весьма неудобно читать, если он написан в одну строчку</nobr>
Категория
Теги форматирования текста


OBJECT

Тег OBJECT

Тег <OBJECT> внедряет объект в html-страницу. Объект может находиться как в HEAD, так и BODY. Закрывающий тег требуется

Атрибуты
CLASSID
Устанавливает или восстанавливает идентификатор класса для объекта
id
Получает строку, идентифицирующую объект
style
Устанавливает стиль для объекта Пример

Приведем несколько примеров для объекта Shell

Категория
Другие


offsetWidth

Свойство offsetHeight

Свойство offsetHeight возвращает высоту объекта относительно родительского объекта. Например, можно использовать для определения истинного размера окна, если браузер открыт не в максимизированном окне, если в браузере применяются боковые панели, если страничка открыта во фрейме и т.п.

Синтаксис

[ iHeight = ] object.offsetHeight
iHeight является числовым значением ширины в пикселах

Свойство offsetWidth

Свойство offsetWidth возвращает ширину объекта относительно родительского объекта. Например, можно использовать для определения истинного размера окна, если браузер открыт не в максимизированном окне, если в браузере применяются боковые панели, если страничка открыта во фрейме и т.п.

Синтаксис

[ iWidth = ] object.offsetWidth
iWidth является числовым значением ширины в пикселах

Пример

Нажмите на кнопку для получения ширины документа в браузере. Можете изменять размеры окна


OL

Тег <OL> и обязательный парный ему </OL>

Тег <OL>(Ordered List) служит для создания нумерованного списка. Допускается вложение нумерованного списка в списки другого вида

Атрибуты
type
Тип маркера
A | Заглавные буквы
a | Строчные буквы
I | Заглавные римские цифры
i | Строчные римские цифры
1 | Арабские цифры (по умолчанию)
start
Начальное значение для нумерованного списка при использовании арабских цифр
title
Всплывающая подсказка Пример
  1. Пугачева
  2. Орбакайте
  3. Киркоров
  4. Пресняков
А выглядит код так:
<OL type=A title="нумерованный список">
<LI>Пугачева
<LI>Орбакайте
<LI>Киркоров
<LI>Пресняков
</OL>
Категория
Списки


OPTGROUP

Тег OPTGROUP

Тег OPTGROUP позволяет группировать элементы в SELECT в логические группы. Требуется закрывающий тег

Атрибуты

label
Задает имя для заданной группы
Пример

Категория
Элементы управления


OPTION

Тег <option> и необязательный парный ему </option>

Каждый элемент SELECT должен содержать хотя бы один или более элементов OPTION, с помощью которого создаются строки списков

Атрибуты
selected
Индикатор, что данная строка является выбранной по умолчанию. Если данный индикатор отсутствует, то такой строкой является первый элемент
Пример

Код для примера

<select size=3>
<option>Это список с прокруткой
<option>Вторая строка
<option>Третья строка
<option selected>Четвертая строка</select>
Категория
Элементы управления


P

Тег <P> и необязательный парный ему </P>

Тег <P> создает новый параграф. Два или более тега <P>, идущих подряд, заменяются одним

Параметры
align
Выравнивает параграф относительно одной из сторон документа, значения: left, right, или center
left | выравнивание по левому краю. По умолчанию
right | выравнивание по правому краю
center | выравнивание по центру
justify | выравнивание по ширине
title
Всплывающая подсказка
Пример

Выравниваем параграф по правому краю с помощью соответствующего атрибута <p align="right">

Категория
Теги форматирования текста


PRE

Тег <PRE> и обязательный парный ему </PRE>

Тег <PRE> обрамляет предварительно отформатированный текст. Преформатированный текст отображается моношириным шрифтом. Получается как бы текстовая вставка в html

Пример
Буря мглою небо кроет,
 ... То завоет как дитя
Категория
Теги форматирования текста


Q

Тег <Q> предназначен для включения в документ короткой цитаты без создания отступов (сравни с BLOCKQUOTE). Закрывающий тег обязателен

Атрибуты
contentEditable
Возможность редактирования
title
Всплывающая подсказка
Пример

Он сказал: "Поехали!"

Категория
Теги форматирования текста


S

Тег <s> и обязательный парный ему </s>

Тег <s> указывает, что текст должен быть зачеркнут

Пример

Это обычный текст
А это уже текст с использованием тега <s>

Категория
Теги физического форматирования текста


SAMP

Тег <SAMP> и обязательный парный ему </SAMP>

Тег <SAMP> отмечает текст как образец (sample). Используется для отметки текста, выдаваемого программами. Отображается моноширинным шрифтом

Пример

Это обычный текст
А это уже текст с использованием тега <samp>

Категория
Теги логического форматирования текста


SCRIPT

Тег <SCRIPT>

Элемент SCRIPT используется для включения небольших программ - скриптов (JavaScript, VBScript). При помощи скриптов можно достаточно легко создавать интерактивные страницы. Если броузер не поддерживает сценарии, то содержимое контейнера SCRIPT может быть выведено на экран. Чтобы этого не случилось, весь текст программы вкладывают в комментарий, а поясняющий текст помещают внутрь контейнера NOSCRIPT. Обратите также внимание на то, что закрывающему тегу комментария предшествует комментарий на языке JavaScript (//). Это делается для того, чтобы интерпретатор JavaScript не выдал ошибки, дойдя до символов «чужеродной» конструкции HTML. Закрывающий тег: требуется

Атрибуты
language
Определяет язык скрипта. Может иметь следующие значения: JScript, javascript, vbs, vbscript, XML
src
Содержит ссылку на внешний файл, содержащий скрипт

Пример

А выглядит код так:
<script language="VBScript">
Sub clickme()
 Alert "Молодец! Не побоялись нажать на меня!"
End Sub
</script>
<button onclick="clickme()">Нажми меня!</button>
Категория
Другие теги


SELECT

Тег <select> и обязательный парный ему </select>

Тег <select> создает список или выпадающий список. Каждый элемент списка описывается тегом Option

Атрибуты
size
Число отображаемых элементов. Если равно 1 или не указано, то выводится одна строчка. Если значение больше 1, то выводится список с прокруткой
Пример

Приведем пример подобия pull-down меню для навигации по сайту

Вот код:

<SELECT NAME="navSelect"
ONCHANGE="top.location.href =
this.options[this.selectedIndex].value">
<OPTION>Выбор раздела</OPTION>
<OPTION VALUE="1.html">1 страница</OPTION>
<OPTION VALUE="2.html">2 страница</OPTION>
<OPTION VALUE="3.html">3 страница</OPTION>
<OPTION VALUE="4.html">4 страница</OPTION>
<OPTION VALUE="5.html">5 страница</OPTION>
</SELECT>

Основную работу выполняет обработчик события ONCHANGE. top ссылается на окно браузера, активное в данный момент. top.location.href - URL документа, отображаемого этим окном. Одним из свойств объекта SELECT является коллекция options, которая содержит параметры элементов выбора. Например navSelect.option[1].value содержит значение "index.html". Свойство элемента SELECT selectedIndex - номер выбранного пункта. Элемент this внутри элемента ссылается именно на этот элемент. Вместо него можно было использовать (в Internet Explorer) ссылку document.all.navSelect, но this гораздо короче и работает в обоих браузерах. Я советую вам всегда использовать элемент this, когда это возможно.

Приведем еще один пример, когда пользователь сначала выбирает пункт из списка и потом щелкает на кнопке

Вот код:

<FORM>
SELECT NAME="navSelect"<>
<OPTION>Выбор раздела</OPTION>
<OPTION VALUE="1.html">1 страница</OPTION>
<OPTION VALUE="2.html">2 страница</OPTION>
<OPTION VALUE="3.html">3 страница</OPTION>
</SELECT><BR>
<INPUT TYPE=BUTTON NAME="go" VALUE="Go!"
ONCLICK="top.location.href =
this.form.navSelect.options[this.form.navSelect.selectedIndex].value">
</FORM>

Здесь необходимо пояснить, что каждый элемент формы имеет свойство form, которое содержит ссылку на его родительскую форму. Таким образом можно сослаться на любой элемент формы из любого другого элемента, чем мы здесь и воспользовались: this.form.navSelect ссылается именно на элемент выбора.

Категория
Элементы управления


SMALL

Тег <SMALL> и обязательный парный ему </SMALL>

Тег <SMALL> выводит более мелкий текст

Атрибуты
title
Показывает текст в виде всплывающей подсказки
Пример

Это обычный текст
А это уже более мелкий текст с использованием тега <SMALL>

Категория
Теги физического форматирования текста


SPAN

Тег <SPAN>

Элемент SPAN определяет контейнер для внутреннего текста. Данный элемент предназначен для использования в CSS. Закрывающий тег: требуется

Атрибуты
contentEditable
Возможность редактирования
title
Всплывающая подсказка
UNSELECTABLE
Запрещает или разрешает выделять текст в данном элементе (on - запрещает, off - разрешает)

Пример

Строка содержит одно слово красного цвета. Причем это слово нельзя выделить.

А выглядит код так:

<P>Строка содержит одно слово <SPAN STYLE="color:red">красного</SPAN> цвета.
Категория
Другие теги


STRONG

Тег <strong> и обязательный парный ему </strong>

Тег <strong> используется для выделения из текста слова (жирный текст). Происходит от слова strong emphasis - сильный акцент. Аналогичен тегу B

Пример

Это обычный текст
А это уже текст с использованием тега <strong>

Категория
Теги логического форматирования текста


STYLE

Тег <STYLE>

Элемент STYLE задает правила оформления и форматирования странички. Всегда используется внутри HEAD. Подробнее о стилях читайте в главе Что такое CSS. Закрывающий тег: требуется

Атрибуты
innetHTML
Sets or retrieves the HTML between the start and end tags of the object

Пример

Зададим для заголовков H3 зеленый цвет, а для тега B красный цвет с помощью STYLE. Смотрите код страницы, чтобы понять, как это работает

Категория
Другие теги


SUB

Тег <sub> и обязательный парный ему </sub>

Тег <sub> приспускает текст

Пример

Текст с использованием тега <sub>
Формула воды - H2O

Категория
Теги физического форматирования текста


SUP

Тег <sup> и обязательный парный ему </sup>

Тег <sup> приподнимает текст

Пример

Текст с использованием тега <sup>
42 = 16

Категория
Теги физического форматирования текста


TABLE

Тег <TABLE>

Тег <TABLE> создает таблицу. Все прочие элементы таблицы должны быть вложенными в него. Допускается также вложение таблиц одна в другую, т.е. содержимым ячейки может быть другая таблица. Закрывающий тег обязателен

Атрибуты
align
Выравнивание таблицы относительно документа. Возможные значения: center, left, right
background
Строка, определяющая рисунок для заднего фона
bgcolor
Определяет задний фон таблицы
border
Толщина рамки в пикселах. Если атрибут не указан, то таблица выводится без видимой рамки
bordercolor
Цвет рамки
cellspacing
Задает расстояние между ячейками таблицы
cellpadding
Задает расстояние между содержимым ячейки и ее рамкой
rules
Описывает рамки вокруг таблицы. Может принимать следующие значения
all | Отображает все части рамки внутри таблицы
cols | Отображает все вертикальные рамки внутри таблицы
groups | Отображает горизонтальные части рамки между группами таблицы THEAD, TBODY, TFOOT
none | Удаляет все рамки вокруг таблицы
rows | Отображает все горизонтальные рамки внутри таблицы
summary
Описание таблицы для удобства людей, использующих браузеры, поддерживающие азбуку Бройля или речевой вывод
title
Всплывающая подсказка
width
Ширина таблицы в процентах или пикселах
Пример

Пример простой таблицы
Заголовок столбца 1 | Заголовок столбца 2
Ячейка столбца 1, ряд 1 | Ячейка столбца 2, ряд 1
Ячейка столбца 1, ряд 2 | Ячейка столбца 2, ряд 2

Код для таблицы
<TABLE BORDER=2 COLS=2 BGCOLOR=yellow align=center>
 <TR>
  <TH>Заголовок столбца 1</TH><TH>Заголовок столбца 2</TH>
 </TR>
 <TR>
  <TD>Ячейка столбца 1, ряд 1</TD><TD>Ячейка столбца 2, ряд 1</TD>
 </TR>
 <TR>
  <TD>Ячейка столбца 1, ряд 2</TD><TD>Ячейка столбца 2, ряд 2</TD>
 </TR>
</TABLE>
Категория
Таблицы


TD

Тег TD

Тег <TD> определяет отдельную ячейку в таблице. Закрывающий тег не обязателен, но желателен

Атрибуты
height
Указывает высоту элемента в процентах или пикселях
align
Выравнивает текст в ячейке
  • left - по левому краю (по умолчанию)
  • rigth - по правому краю
  • center - по центру
valign
Выравнивает текст в ячейке по вертикали
  • top - по верхнему краю
  • middle - по центру
  • bottom - по нижнему краю
colspan
Указывает кол-во столбцев которое объединено в одной ячейке (по умолчанию=1)
rowspan
Указывает кол-во строк которое объединено в одной ячейке (по умолчанию=1)
title
Всплывающая подсказка
Пример

Пример простой таблицы
Заголовок столбца 1 | Заголовок столбца 2
Ячейка столбца 1, ряд 1 | Ячейка столбца 2, ряд первый
Ячейка столбца 1, ряд второй | Ячейка столбца 2, ряд 2

Код для таблицы
<TABLE BORDER=2 COLS=2>
 <TR>
  <TH>Заголовок столбца 1</TH><TH>Заголовок столбца 2</TH>
 </TR>
 <TR align=right>
  <TD height=70 title="пример">Ячейка столбца 1, ряд 1</TD><TD>Ячейка столбца 2, ряд первый</TD>
 </TR>
 <TR align=center>
  <TD>Ячейка столбца первый, ряд 2</TD><TD>Ячейка столбца 2, ряд 2</TD>
 </TR>
</TABLE>
Категория
Таблицы


TEXTAREA

Тег <TEXTAREA>

Тег TEXTAREA создает многострочное текстовое поле для ввода информации. По умолчанию тег создает пустое поле шириной в 20 символов и состоящее из двух строк. Выводимый текст находится между тегами. Требуется закрывающий тег.

Атрибуты
cols=
Определяет ширину поля в символах
disabled
Делает элемент недоступным
readonly
Текст только для чтения. Нельзя изменять, вставлять и т.д.
rows=
Определяет число строк
title=
Всплывающая подсказка
Пример

Код
<textarea cols=11 rows=7 readonly>
Текстовое поле шириной в 11 символов и в семь строк <textarea/>
Категория
Элементы управления


TH

Тег <TH>

Тег <TH> определяет заголовок для столбца в таблице. Обычно, выделяются жирным шрифтом. Закрывающий тег обязателен

Атрибуты
bgcolor
Цвет фона
bordercolor
Цвет рамки для элемента
height
Указывает высоту элемента в процентах или пикселях
align
Выравнивает текст в ячейке
  • left - по левому краю (по умолчанию)
  • rigth - по правому краю
  • center - по центру
valign
Выравнивает текст в ячейке по вертикали
  • top - по верхнему краю
  • middle - по центру
  • bottom - по нижнему краю
colspan
Указывает кол-во столбцев которое объединено в одной ячейке (по умолчанию=1)
rowspan
Указывает кол-во строк которое объединено в одной ячейке (по умолчанию=1)
title
Всплывающая подсказка
Пример

Пример простой таблицы
Заголовок столбца 1 | Заголовок столбца 2
Ячейка столбца 1, ряд 1 | Ячейка столбца 2, ряд первый
Ячейка столбца 1, ряд второй | Ячейка столбца 2, ряд 2

Код для таблицы
<TABLE BORDER=2 COLS=2>
 <TR>
  <TH>Заголовок столбца 1</TH><TH>Заголовок столбца 2</TH>
 </TR>
 <TR align=right>
  <TD height=70 title="пример">Ячейка столбца 1, ряд 1</TD><TD>Ячейка столбца 2, ряд первый</TD>
 </TR>
 <TR align=center>
  <TD>Ячейка столбца первый, ряд 2</TD><TD>Ячейка столбца 2, ряд 2</TD>
 </TR>
</TABLE>
Категория
Таблицы


THEAD

Тег <THEAD>

Тег THEAD определяет заголовок таблицы, содержащий информацию о столбцах таблицы. В таблице может быть только один THEAD. Внутри заголовка допустимо использовать теги TR, TH, TD. Закрывающий тег необязателен

Атрибуты
title
Всплывающая подсказка
Пример
Текст для заголовка таблицы
Текст для тела таблицы
Категория
Таблицы


TITLE

Тег <TITLE> и обязательный парный ему </TITLE>

Элемент TITLE не является частью отображаемого текста. Он может отображаться, например, как заголовок страницы или название окна. Только один TITLE может быть в документе. Элемент TITLE должен использоваться для идентификации содержимого документа. Поскольку пользователи часто обращаются к документам вне контекста, авторы должны предоставлять осмысленные заголовки. Таким образом, вместо такого заголовка, как "Введение", который не даёт достаточно информации о документе, авторы должны записать, например, так: "Введение в HTML". Название должно быть не более 40 символов, т.к. название, привышающее размер в 40 символов непомещается в строку заголовка окна браузера.

Категория
Теги форматирования документа


TR

Тег <TR> и необязательный парный ему </TR>

Тег <TR> определяет строку в таблице

Атрибуты
align
Выравнивает текст в ячейке
  • left - по левому краю
  • rigth - по правому краю
  • center - по центру
valign
Выравнивает текст в ячейке по вертикали
  • top - по верхнему краю
  • middle - по центру
  • bottom - по нижнему краю
Пример

Пример простой таблицы
Заголовок столбца 1 | Заголовок столбца 2
Ячейка столбца 1, ряд 1 | Ячейка столбца 2, ряд первый
Ячейка столбца 1, ряд второй | Ячейка столбца 2, ряд 2

Код для таблицы
<TABLE BORDER=2 COLS=2>
 <TR>
  <TH>Заголовок столбца 1</TH><TH>Заголовок столбца 2</TH>
 </TR>
 <TR align=right>
  <TD>Ячейка столбца 1, ряд 1</TD><TD>Ячейка столбца 2, ряд первый</TD>
 </TR>
 <TR align=center>
  <TD>Ячейка столбца первый, ряд 2</TD><TD>Ячейка столбца 2, ряд 2</TD>
 </TR>
</TABLE>
Категория
Таблицы


TT

Тег <tt> и обязательный парный ему </tt>

Тег <tt> создает текст, имитирующий стиль печатной машинки

Пример

Это обычный текст
А это уже текст с использованием тега <tt>,имитирующий стиль печатной машинки

Категория
Теги физического форматирования текста


U

Тег <u> и обязательный парный ему </u>

Тег <u> указывает, что текст должен быть подчеркнут

Пример

Это обычный текст
А это уже текст с использованием тега <u>

Категория
Теги физического форматирования текста


UL

Тег <UL>

Тег <UL>(Unordered List) служит для создания ненумерованного списка. Допускается вложение ненумерованного списка в списки другого вида. Требуется закрывающий тег

Атрибуты
type
Тип маркера
disk | Закрашенный кружок. По умолчанию
circle | Незакрашенный кружок
square | Квадратик
title
Всплывающая подсказка
Пример
  • Пугачева
  • Орбакайте
  • Киркоров
  • Пресняков
А выглядит код так:
<UL type=square title="Ненумерованный список">
<LI>Пугачева
<LI>Орбакайте
<LI>Киркоров
<LI>Пресняков
</UL>
Категория
Списки


VAR

Тег <VAR> и обязательный парный ему </VAR>

Тег <VAR> используется для выделения переменных в листинге программы. Обычно такой текст отображается курсивом. От английского variable - переменная

Пример

function() - фунция

Код для примера
<var>function()</var> - фунция

Категория
Теги логического форматирования текста


Color

Таблица базовых цветов BgColor

Aliceblue F0F8FF | Antiquewhite FAEBD7 | Aqua 00FFFF | Aquamarine 7FFFD4
Azure F0FFFF | Beige F5F5DC | Bisque FFE4C4 | Black 000000
Blanchedalmond FFEBCD | Blue 0000FF | Blueviolet 8A2BE2 | Brown A52A2A
Burlywood DEB887 | Cadetblue 5F9EA0 | Chartreuse 7FFF00 | Chocolate D2691E
Coral FF7F50 | Cornflowerblue 6495ED | Cornsilk FFF8DC | Crimson DC143C
Cyan 00FFFF | Darkblue 00008B | Darkcyan 008B8B | Darkgoldenrod B8860B
Darkgray A9A9A9 | Darkgreen 006400 | Darkkhaki BDB76B | Darkmagenta 8B008B
Darkolivegreen 556B2F | Darkorange FF8C00 | Darkorchid 9932CC | Darkred 8B0000
Darksalmon E9967A | Darkseagreen 8FBC8F | Darkslateblue 483D8B | Darkslategray 2F4F4F
Darkturquoise 00CED1 | Darkviolet 9400D3 | deeppink FF1493 | Deepskyblue 00BFFF
Dimgray 696969 | Dodgerblue 1E90FF | Firebrick B22222 | Floralwhite FFFAF0
Forestgreen 228B22 | Fuchsia FF00FF | Gainsboro DCDCDC | Ghostwhite F8F8FF
Gold FFD700 | Goldenrod DAA520 | Gray 808080 | Green 008000
Greenyellow ADFF2F | Honeydew F0FFF0 | Hotpink FF69B4 | Indianred CD5C5C
Indigo 4B0082 | Ivory FFFFF0 | Khaki F0E68C | Lavendar E6E6FA
Lavenderblush FFF0F5 | Lawngreen 7CFC00 | Lemonchiffon FFFACD | Lightblue ADD8E6
Lightcoral F08080 | Lightcyan E0FFFF | Lightgoldenrodyellow FAFAD2 | Lightgreen 90EE90
Lightgrey D3D3D3 | Lightpink FFB6C1 | Lightsalmon FFA07A | Lightseagreen 20B2AA
Lightskyblue 87CEFA | Lightslategray 778899 | Lightsteelblue B0C4DE | Lightyellow FFFFE0
Lime 00FF00 | Limegreen 32CD32 | Linen FAF0E6 | Magenta FF00FF
Maroon 800000 | Mediumauqamarine 66CDAA | Mediumblue 0000CD | Mediumorchid BA55D3
Mediumpurple 9370D8 | Mediumseagreen 3CB371 | Mediumslateblue 7B68EE | Mediumspringgreen 00FA9A
Mediumturquoise 48D1CC | Mediumvioletred C71585 | Midnightblue 191970 | Mintcream F5FFFA
Mistyrose FFE4E1 | Moccasin FFE4B5 | Navajowhite FFDEAD | Navy 000080
Oldlace FDF5E6 | Olive 808000 | Olivedrab 688E23 | Orange FFA500
Orangered FF4500 | Orchid DA70D6 | Palegoldenrod EEE8AA | Palegreen 98FB98
Paleturquoise AFEEEE | Palevioletred D87093 | Papayawhip FFEFD5 | Peachpuff FFDAB9
Peru CD853F | Pink FFC0CB | Plum DDA0DD | Powderblue B0E0E6
Purple 800080 | Red FF0000 | Rosybrown BC8F8F | Royalblue 4169E1
Saddlebrown 8B4513 | Salmon FA8072 | Sandybrown F4A460 | Seagreen 2E8B57
Seashell FFF5EE | Sienna A0522D | Silver C0C0C0 | Skyblue 87CEEB
Slateblue 6A5ACD | Slategray 708090 | Snow FFFAFA | Springgreen 00FF7F
Steelblue 4682B4 | Tan D2B48C | Teal 008080 | Thistle D8BFD8
Tomato FF6347 | Turquoise 40E0D0 | Violet EE82EE | Wheat F5DEB3
White FFFFFF | Whitesmoke F5F5F5 | Yellow FFFF00 | YellowGreen 9ACD32


Специальные символы

Некоторые символы не входят в базовую часть таблицы кодов ASCII. К ним относятся буквы алфавитов части европейских языков, математические и некоторые другие символы. Некоторые символы, введенные в HTML документ будут интерпретироваться не так, как задумал автор. Это, например, символы "<" и ">", используемые для указания тегов.

В этих случаях можно вводить нужные символы с помощью специальных кодов. Коды начинаются с символа "амперсанд"(&). За ним следует название символа либо его числовой код в десятичной или шестнадцатеричной системе. Завершает код символ "точка с запятой"(;).

В спецификации HTML указано большое количество спецсимволов, но только некоторые из них используются. Наиболее часто используемые спецсимволы приведены в таблице:
Имя | Код | Вид | Описание
&quot;&#34;"двойная кавычка
&amp;&#38;&амперсанд
&lt;&#60;<знак 'меньше'
&gt;&#62;>знак 'больше'
&nbsp; | &#160; | неразрывный пробел
&iexcl;&#161;¡перевернутый восклицательный знак
&cent;&#162;¢цент
&pound;&#163;£фунт стерлингов
&curren;&#164;¤денежная единица
&yen;&#165;¥иена или юань
&brvbar;&#166;¦разорванная вертикальная черта
&sect;&#167;§параграф
&uml;&#168;¨умляут
&copy;&#169;©знак copyright
&ordf; | &#170; | ª | женский порядковый числитель
&laquo;&#171;«левая двойная угловая скобка
&not;&#172;¬знак отрицания
&shy; | &#173; | место возможного переноса
&reg;&#174;®знак зарегистрированной торговой марки
&macr;&#175;¯верхняя горизонтальная черта
&deg;&#176;°градус
&plusmn;&#177;±плюс-минус
&sup2; | &#178; | ² | "в квадрате"
&sup3; | &#179; | ³ | "в кубе"
&acute;&#180;´знак ударения
&micro; | &#181; | µ | микро
&para;&#182;¶символ параграфа
&middot;&#183;·точка
&cedil;&#184;¸седиль (орфографический знак)
&sup1; | &#185; | ¹ | верхний индекс 'один'
&ordm; | &#186; | º | мужской порядковый числитель
&raquo;&#187;»правая двойная угловая скобка
&frac14; | &#188; | ¼ | одна четвертая
&frac12; | &#189; | ½ | одна вторая
&frac34; | &#190; | ¾ | три четвертых
&iquest;&#191;¿перевернутый вопросительный знак
&Agrave; | &#192; | À | латинская заглавная А с тупым ударением
&Aacute; | &#193; | Á | латинская заглавная А с острым ударением
&Acirc; | &#194; | Â | латинская заглавная А с диакритическим знаком над гласной
&Atilde; | &#195; | Ã | латинская заглавная А с тильдой
&Auml; | &#196; | Ä | латинская заглавная А с двумя точками
&Aring; | &#197; | Å | латинская заглавная А с верхним кружком
&AElig; | &#198; | Æ | латинские заглавные символы AE вместе
&Ccedil; | &#199; | Ç | латинская заглавная C с седилем
&Egrave; | &#200; | È | латинская заглавная E с тупым ударением
&Eacute; | &#201; | É | латинская заглавная E с острым ударением
&Ecirc; | &#202; | Ê | латинская заглавная E с диакритическим знаком над гласной
&Euml; | &#203; | Ë | латинская заглавная E с двумя точками
&Igrave; | &#204; | Ì | латинская заглавная I с тупым ударением
&Iacute; | &#205; | Í | латинская заглавная I с острым ударением
&Icirc; | &#206; | Î | латинская заглавная I с диакритическим знаком над гласной
&Iuml; | &#207; | Ï | латинская заглавная I с двумя точками
&ETH; | &#208; | Ð | латинская заглавная D с черточкой
&Ntilde; | &#209; | Ñ | латинская заглавная N с тильдой
&Ograve; | &#210; | Ò | латинская заглавная O с тупым ударением
&Oacute; | &#211; | Ó | латинская заглавная O с острым ударением
&Ocirc; | &#212; | Ô | латинская заглавная O с диакритическим знаком над гласной
&Otilde; | &#213; | Õ | латинская заглавная O с тильдой
&Ouml; | &#214; | Ö | латинская заглавная O с двумя точками
&times;&#215;×знак умножения
&Oslash; | &#216; | Ø | латинская заглавная O со штрихом
&Ugrave; | &#217; | Ù | латинская заглавная U с тупым ударением
&Uacute; | &#218; | Ú | латинская заглавная U с острым ударением
&Ucirc; | &#219; | Û | латинская заглавная U с диакритическим знаком
&Uuml; | &#220; | Ü | латинская заглавная U с двумя точками
&Yacute; | &#221; | Ý | латинская заглавная Y с острым ударением
&THORN; | &#222; | Þ | латинская заглавная THORN
&agrave; | &#224; | à | латинская строчная a с тупым ударением
&aacute; | &##225; | á | латинская строчная a с острым ударением
&acirc; | &##226; | â | латинская строчная a с диакритическим знаком
&atilde; | &#227; | ã | латинская строчная a с тильдой
&auml; | &#228; | ä | латинская строчная a с двумя точками
&aring; | &#229; | å | латинская строчная a с верхним кружком
&aelig; | &#230; | æ | латинская строчные буквы ae
&ccedil; | &#231; | ç | латинская строчная c с седилем
&egrave; | &#232; | è | латинская строчная e с тупым ударением
&eacute; | &#233; | é | латинская строчная e с острым ударением
&ecirc; | &#234; | ê | латинская строчная e с диакритическим знаком
&euml; | &#235; | ë | латинская строчная e с двумя точками
&igrave; | &#236; | ì | латинская строчная I с тупым ударением
&iacute; | &#237; | í | латинская строчная I с острым ударением
&icirc; | &#238; | î | латинская строчная I с диакритическим знаком
&iuml; | &#239; | ï | латинская строчная I с двумя точками
&eth; | &#240; | ð | латинская строчные символы eth
&ntilde; | &#241; | ñ | латинская строчная N с тильдой
&ograve; | &#242; | ò | латинская строчная O с тупым ударением
&oacute; | &#243; | ó | латинская строчная O с острым ударением
&ocirc; | &#244; | ô | латинская строчная O с диакритическим знаком
&otilde; | &#245; | õ | латинская строчная I с тильдой
&ouml; | &#246; | ö | латинская строчная I с двумя точками
&divide;&#247;÷знак деления
&oslash; | &#248; | ø | латинская строчная O со штрихом
&ugrave; | &#249; | ù | латинская строчная U с тупым ударением
&uacute; | &#250; | ú | латинская строчная U с острым ударением
&ucirc; | &#251; | û | латинская строчная U с диакритическим знаком
&uuml; | &#252; | ü | латинская строчная U с двумя точками
&yacute; | &#253; | ý | латинская строчная Y с острым ударением
&thorn; | &#254; | þ | латинская строчная thorn
&yuml; | &#255; | ÿ | латинская строчная Y с двумя точками
&fnof; | &#402; | ƒ | знак функции

Символы для букв

&circ; | &#710; | ˆ | диакритический знак над гласной
&tilde;&#732;˜тильда

Греческие буквы
&Alpha; | &#913; | Α | заглавная альфа
&Beta; | &#914; | Β | заглавная бета
&Gamma; | &#915; | Γ | заглавная гамма
&Delta; | &#916; | Δ | заглавная дельта
&Epsilon; | &#917; | Ε | заглавная эпсилон
&Zeta; | &#918; | Ζ | заглавная дзета
&Eta; | &#919; | Η | заглавная эта
&Theta; | &#920; | Θ | заглавная тета
&Iota; | &#921; | Ι | заглавная иота
&Kappa; | &#922; | Κ | заглавная каппа
&Lambda; | &#923; | Λ | заглавная лямбда
&Mu; | &#924; | Μ | заглавная мю
&Nu; | &#925; | Ν | заглавная ню
&Xi; | &#926; | Ξ | заглавная кси
&Omicron; | &#927; | Ο | заглавная омикрон
&Pi; | &#928; | Π | заглавная пи
&Rho; | &#929; | Ρ | заглавная ро
&Sigma; | &#931; | Σ | заглавная сигма
&Tau; | &#932; | Τ | заглавная тау
&Upsilon; | &#933; | Υ | заглавная ипсилон
&Phi; | &#934; | Φ | заглавная фи
&Chi; | &#935; | Χ | заглавная хи
&Psi; | &#936; | Ψ | заглавная пси
&Omega; | &#937; | Ω | заглавная омега
&alpha; | &#945; | α | строчная альфа
&beta; | &#946; | β | строчная бета
&gamma; | &#947; | γ | строчная гамма
&delta; | &#948; | δ | строчная дельта
&epsilon; | &#949; | ε | строчная эпсилон
&zeta; | &#950; | ζ | строчная дзета
&eta; | &#951; | η | строчная эта
&theta; | &#952; | θ | строчная тета
&iota; | &#953; | ι | строчная иота
&kappa; | &#954; | κ | строчная каппа
&lambda; | &#955; | λ | строчная лямбда
&mu; | &#956; | μ | строчная мю
&nu; | &#957; | ν | строчная ню
&xi; | &#958; | ξ | строчная кси
&omicron; | &#959; | ο | строчная омикрон
&pi; | &#960; | π | строчная пи
&rho; | &#961; | ρ | строчная ро
&sigmaf; | &#962; | ς | строчная сигма (final)
&sigma; | &#963; | σ | строчная сигма
&tau; | &#964; | τ | строчная тау
&upsilon; | &#965; | υ | строчная ипсилон
&phi; | &#966; | φ | строчная фи
&chi; | &#967; | χ | строчная хи
&psi; | &#968; | ψ | строчная пси
&omega; | &#969; | ω | строчная омега

Общая пунктуация

&ndash;&#8211;–тире
&mdash;&#8212;—длинное тире
&lsquo;&#8216;‘левая одиночная кавычка
&rsquo;&#8217;’правая одиночная кавычка
&sbquo;&#8218;‚нижняя одиночная кавычка
&ldquo;&#8220;“левая двойная кавычка
&rdquo;&#8221;”правая двойная кавычка
&bdquo;&#8222;„нижняя двойная кавычка

Прочие символы

&dagger;&#8224†латинский крест
&Dagger;&#8225‡двойной крест
&bull;&#8226;•маленький черный кружок
&hellip;&#8230;…многоточие ...
&#8240;‰знак промилле (процент с дополнительным ноликом)
&prime;&#8242; ′одиночный штрих - минуты
&Prime;&#8243; ″двойной штрих - секунды
&oline;&#8254; ‾надчеркивание
&frasl;&#8260; ⁄косая дробная черта
&euro;&#8364;€евро
&#8470;№знак номера
&trade;&#8482;™знак торговой марки
&loz;&#9674◊ромб
&#9675○круг

Стрелки

&larr;&#8592; ←стрелка влево
&uarr;&#8593; ↑стрелка вверх
&rarr;&#8594; →стрелка вправо
&darr;&#8595; ↓стрелка вниз
&harr;&#8596; ↔стрелка влево-вправо
&#8597;↕стрелка вверх-вниз

Масти

&spades;&#9824; ♠знак масти 'пики'
&clubs;&#9827; ♣знак масти 'трефы'
&hearts;&#9829; ♥знак масти 'червы'
&diams;&#9830; ♦знак масти 'бубны'


Теги HTML

Теги по категориям

    Гиперссылки
    Графика
    Таблицы
    Теги форматировния документа
    Теги физического форматирования текста
    Теги логического форматирования текста
    Списки
    Элементы управления
    Фреймы
    Звук
    Другие теги

    Гиперссылки
  • A
    Графика
  • IMG
    Таблицы
  • CAPTION
  • TABLE
  • TH
  • THEAD
  • TD
  • TR
    Теги форматировния документа
  • BASE
  • BODY
  • HEAD
  • HTML
  • META
  • TITLE
    Теги физического форматирования текста
  • B
  • BIG
  • BLOCKQUOTE
  • BR
  • FONT
  • Hx
  • HR
  • I
  • MARQUEE
  • NOBR
  • P
  • PRE
  • Q
  • S
  • SMALL
  • SUB
  • SUP
  • TT
  • U
    Теги логического форматирования текста
  • ABBR
  • ACRONYM
  • CITE
  • CODE
  • DFN
  • EM
  • KBD
  • SAMP
  • STRONG
  • VAR
    Списки
  • DD
  • DL
  • DT
  • LI
  • MENU
  • OL
  • UL
    Элементы управления
  • BUTTON
  • FIELDSET
  • INPUT
  • OPTGROUP
  • OPTION
  • SELECT
  • TEXTAREA
    Фреймы
  • IFRAME
    Звук
  • BGSOUND
    Другие теги
  • !--
  • !DOCTYPE
  • ADDRESS
  • APPLET
  • AREA
  • CENTER
  • DIV
  • FORM
  • LEGEND
  • LINK
  • MAP
  • OBJECT
  • SCRIPT
  • SPAN